Posted Sat, 07 Feb 2015 01:12:14 GMT by Russ Parker

Some of the commands on the AS 2015.1 tool palette are not working. Mostly on the features. Is this a known issue and is there a fix for it?

Posted Sun, 08 Feb 2015 19:42:12 GMT by Russ Parker

Command: _AstM4CrConByVB RailingJointHandrail
CreateInstance failed (file =  C:\Program Files\Autodesk\Advance Steel 2015.1\Shared\Joints\Bin\Railing10x64.dll)!

This is the command line text when trying to use commands that worked in AS 2014. If these commands are no longer available or the the command text has changed, how are we to know which ones will work and which ones won't? Is there a list of commands that are gone or even better, a list of the commands the previous ones have been replaced with? This is most important to have fixed.

Thank you.

Posted Mon, 09 Feb 2015 16:38:18 GMT by

To our knowledge all the features work fine. I have tested all the features with the 2015.1 version and they work fine. Please tell us when and how a particular feature is failing? There are features for different type of model objects that you must take into consideration when applying them.

Posted Mon, 09 Feb 2015 16:45:14 GMT by

The command Command: _AstM4CrConByVB RailingJointHandrail  is for elbows. It is now located in the connection vault under the miscellaneous section. I have tested it using the text command and it works fine also... There is a list of command in the user guide which can be found by selecting F1 after launching an advance steel command. You can also contact us at support and we will gladely work thru these issues with you.


Posted Tue, 10 Feb 2015 02:11:05 GMT by Russ Parker

I tried the joint command for elbows that is now located in the connection vault and it did not work. In fact the commands that don't work from the tool palette and the connection vault have one thing in common. They are all looking for the wrong DLL file. The DLL's in the shared Bin folder have the number 64 in the title. The commnads that don't work are looking for a 10x64 in the DLL title.

Has anyone checked this out yet?


Posted Tue, 10 Feb 2015 21:34:49 GMT by Russ Parker

Could someone please respond to my last post? If I'm doing something wrong please let me know. Because either way the commands that aren't working are preventing us from completing our upgrade process.

I have re-installed AS 2015.1 and that did not fix the problem. Since a re-install puts everything back to its default setting then those commands, the joint command in the connection vault is an example, should work just like it did in the 2014 version of AS. But it doesn't.

Am I the only one having this problem? Because if I am then I would appreciate some support from Graitec showing me what I need to fix.

thank you

Posted Wed, 11 Feb 2015 20:11:07 GMT by

As discussed, the problems resides in updating your databases thru the Management Tools.

Let me know if you need further instructions.

Kind regards

You must be signed in to post in this forum.

GRAITEC Services
Free Trial
GRAITEC Products
Advance Design
Advance Workshop
Advance BIM Designers
PowerPack for Revit®
PowerPack for Advance Steel
Autodesk Products
Cloud services
Advance Steel

GRAITEC GROUP 2018 | WE'VE UPDATED OUR PRIVACY NOTICE - Click here to find out more about how we collect, store and handle your personal data and your rights.